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บทคัดยอ  
เนื่องจากปจจบุันนี้ไดเขาสูยคุการเรียนรูแบบไรพรมแดน หรือยุค ไอที การเรียนการสอน

จึงมิไดหยุดอยูที่ในหองเรยีนเทานั้น หากแตการเรียนสมยัใหมตองใชส่ิงของตางๆ รอบตัวเรามาทํา
เปนหองเรยีนไดทันที เชน การเรียนผานทางภูมิปญญาไทยของชุมชน การเรียนเกษตรที่เนนที่
ผลผลิตจริง หรือการเรียนผานทางไกลโดยใชเครือขายอนิเทอรเน็ต  

การจัดทําศูนยความรูเผยแพรผานทางเว็บ เปนการลงทุนที่นอยที่สุดเมือ่เทียบกับการลงทุน
ในการผลิตสื่อดานอื่น และสามารถใชงานไดไมจํากัดครัง้ ไมจํากัดจํานวน และเปนการลงทุนครั้ง
เดียว แตใชเวลาในการใชงานนานมาก  

การจัดทํานกัเรียนสามารถที่จะจดัทําไดดวยตัวนักเรยีนเอง  โดยขอความรูจากที่ปรึกษาใน
ดานการสรางและการจดัทํา จากผูเชี่ยวชาญทางอินเทอรเน็ต  

งบประมาณทีใ่ชในการจัดทาํชื่อเว็บไซต จะเลือกใชงานกับเว็บทีใ่หเนือ้ที่ฟรี เชน 
www.geocities.com หรือ www.yahoo.com สวนการจดัสรางสามารถที่จะจดัทําไดดวยตนเอง  

ประโยชนที่คาดวาจะไดรับ ความรูเกี่ยวกบัการใชงานโปรแกรมประยกุตตางๆ ในการสราง
และจัดทําเว็บไซต การสราง การเพิ่มประสบการณเกีย่วกบัระบบอินเทอรเน็ต เพื่อเปนพื้นฐานใน
การจัดการเรยีนตอไปในอนาคต  

ระยะเวลาในการดําเนินการ ใชเวลาในการสราง 2 เดือน สวนการแกไข (Update) จะเปลี่ยน
ขอมูล ภาคการศึกษาละ 1 คร้ัง  
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กิตติกรรมประกาศ  
โครงงานการจัดทําเว็บเพจ เพื่อนําเสนอประวัติความเปนมาของโรงเรียน ไดรับความ

รวมมือ จากฝายทะเบยีนเพื่อขอประวัติ และทําเนยีบผูบริหาร  
ขอขอบคุณอาจารยและคณาจารยทุกทานทีไ่ดใหความรวมมือในการจดัทํา เกี่ยวกับเนือ้หา

ความรูวิชาตางๆ ที่อาจารยแตละทานรับผิดชอบ  
ขอขอบคุณเวบ็ www.geocities.com ที่มอบเนื้อที่ในการนําเสนอขอมูล  
ขอขอบคุณ ทานผูทรงคุณวฒุิเกี่ยวกับการสรางและการปรับแตงเว็บเพจ รวมทั้งอาจารย 

ประจําวิชา เทคโนโลยีสารสนเทศ ที่ไดมอบความรูเกี่ยวกับการจัดสรางและจัดทําเวบ็ใหสําเร็จลุลวง
ไดดวยดี  

ขอขอบคุณเพือ่นๆ ทุกคน ทีเ่กี่ยวของ ทั้งทีไ่ดเอยช่ือ และไมไดเอยช่ือ ทีช่วยใหการจัดทํา
เว็บเพจ สําเรจ็ลุลวงไดโดยด ี 

        
คณะผูจัดทํา  
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สารบัญ 
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บทที่ 1 

ท่ีมาและความสําคัญ  
เนื่องจากปจจบุันนี้ไดเขาสูยคุการเรียนรูแบบไรพรมแดน หรือยุค ไอที ดังที่ทาน

นายกรัฐมนตร ีพันตํารวจโท ดร. ทักษณิ ชินวัตร กลาวไวในวันเปดการกระชุมเรื่อง การปฏิรูป
การศึกษายุคใหม วา การเรียนยุคใหมมิไดอยูที่การเรียนการสอนในหองเรียนเพยีงอยางเดยีว การ
เรียนคือการแสวงหาความรูส่ิงใหม การเรยีนการสอนจึงมิไดหยุดอยูทีใ่นหองเรยีนเทานั้น หากแต
การเรียนสมัยใหมตองใชส่ิงของตางๆ รอบตัวเรามาทําเปนหองเรียนไดทันที  

ประกอบกับปจจุบันนีก้ารเขามาซึ้งเทคโนโลยีสารสนเทศไดเขามามีบทบาทและ
ความสําคัญอยางยิ่งในการดาํเนินชวีิตปจจบุัน ดังนั้นนักเรียนยุคใหมควรมีความรูพื้นฐานเกีย่วกับ
เทคโนโลยีใหทันยุคทันสมัย เหมาะสมกับวัยและเปนแนวทางในการศกึษาหาความรูตอไปใน
อนาคต  

วัตถุประสงค  
1. เพื่อจัดทําเว็บเพจ เพื่อนําเสนอขอมูล เกี่ยวกบัโรงเรียน  
2. เพื่อเปนแหลงเรียนรูของนักเรียนบุคคลทั่วๆ ไป  
3. เพื่อใหนักเรยีนมีสวนรวมในการจัดทําเวบ็เพจ  
4. เพื่อใหนักเรยีนมีจิตสํานึกในการใชเทคโนโลยีสาระสนเทศ  
 

ขอบเตการศกึษาขอมลู 
1. ศึกษาเกีย่วกับโปรแกรมสรางเว็บเพจ  
2. ศึกษาขอมูลเกีย่วกับ โรงเรียน 
3. รวบรวมขอมลูเกี่ยวกับประวัติ และเนื้อหาความรูวิชาตางๆ ที่อาจารยแตละทาน

รับผิดชอบ 
4. เว็บที่ใหบริการเนื้อที่ฟรี  
5. เทคนิคในการสราง และขอตกลงในการสรางเว็บเพจ  
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บทที่ 2  

เอกสาร 

Macromedia Dreamweaver MX  

โปรแกรม Macromedia Dreamweaver เปนโปรแกรมทีส่รางโดยบริษัท Macromedia ที่ถูก
พัฒนาขึ้นมาหลายเวอรชัน   

โปรแกรม Macromedia Dreamweaver นี้ใชในการออกแบบ สรางเว็บเพ็จ ดวยรูปแบบการ
ทํางานที่เปนลักษณะ แบบ WYSIWYG ซ่ึงยอมาจากคาํวา what you see I what you get หมายความ
วา การสรางงานทุกๆ อยางบนโปรแกรม Dreamweaver มีการแสดงภาพอยางไร เมื่อนาํไปแสดงผล
บน Browser หรือพิมพออกทางเครื่องพิมพ ผลลัพธที่ปรากฏจะเหมือนกับสรางขึ้น จึงเปนการชวย
ทําใหสามารถสรางเว็บเพ็จไดอยางสะดวกรวดเร็ว โดยไมจําเปนที่จะตองเรียนรูภาษา HTML  

การสรางเว็บเพ็จดวยโปรแกรม Macromedia Dreamweaver จะมีนามสกลุเปน. html ซ่ึง
พรอมที่จะนํามา Up load ขึ้นไปใชงานบนอินเทอรเน็ตไดทันที  

การสรางเว็บเพ็จจากโปรแกรม Macromedia Dreamweaver ยังสามารถเพิ่มลูกเลนให
นาสนใจมากยิง่ขึ้นได ดวยการสรางภาพเคลื่อนไหว สรางการโตตอบ จนกระทั่งนําเสนองานใน
รูปแบบมัลติมีเดียกไ็ดเชนกนั  
 
 
 
 
 
 
 
 
 ภาพที่สรางดวย Dreamweaver    การแสดงผลดวยเวบ็ Browser  
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การปรับแตง Dreamweaver อานภาษาไทย 

ในกรณีที่ทานติดตั้ง Dreamweaver โดยปกตินั้นโปรแกรมเองจะยังไมสามารถที่จะอาน
ภาษาไทยได ในปจจุบันนี้ไดมีผูที่เขียน จาวาสคริปต เพื่อกําหนดใหโปรแกรมอานภาษาไทยได
ทันที โดยไมตอง เซตระบบ หรือที่เรียกกันวา Dreamweaver add-on โดยสามารถ Download ได
ทาง อินเทอรเน็ต  
 
 
 
 
 
 
 
 
 

ในกรณีที่ตองการจะปรับแตงเองโดยไมตองพึง Dreamweaver add-on มีวิธีการปรับแตงได
ดังนี้ ขั้นที่ 1การปรับแตงระบบโปรแกรม กบั ขั้นที่ สอง ปรับแตงที่ไฟลงาน  

ขั้นท่ี 1  การปรับแตงระบบโปรแกรม  

การปรับแตงทีร่ะบบโปรแกรม โดยแบบนีจ้ะกําหนดใหทําการปรับแตงครั้งแรก คร้ังเดียว
เทานั้น เพราะครั้งตอไปโปรแกรมจะจําคาไว  

1. คลิกเมนู Edit > Preference  
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2. คลิกที่แท็บ Font  
3. ชอง Font Setting เปลี่ยนเปนแบบ Other  
4. กําหนดที่ชอง Proportional Font เปลี่ยนเปนตัวอักษรแบบ MS San serif (Thai) 
5. กําหนดที่ชอง Code View เปลี่ยนเปนตวัอักษรแบบ MS San serif (Thai) 
6. กําหนดที่ชอง Tag Inspector เปลี่ยนเปนตวัอักษรแบบ MS San serif (Thai) 
7. คลิกปุม OK  

 
 
 
 
 
 
 
 
 
 

ขั้นท่ี 2  การปรับแตงไฟลงาน  

การปรับแตงทีไ่ฟลงาน โดยแบบนี้จะกําหนดใหมทุกครัง้ที่มีการเปดโปรแกรม  
1. คลิกเมนู Modify > Page Properties  
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2. กําหนดที่ชอง Document Encoding โดยกําหนดแบบ Other  
3. คลิกปุม OK  
4. ทดลองพิมพตวัอักษร ภาษาไทย  

 
 
 
 
 
 
 

ขอกําหนดเกี่ยวกับไฟลงาน  

ในกรณีที่จะสรางเว็บเพจ นัน้สิ่งแรกที่ทานตองทําการสรางไดแกไฟลงานแรก โดยไฟล
งานนี้จะตองกาํหนดชื่อวา Index สวนที่หนาตอไปจะตั้งชือ่อยางไรก็ได ขั้นตอนการสรางไฟลงานมี
วิธีการกําหนดไดดังนี้  

1. ในที่นี้จะสรางงานไวทีห่นา Desktop โดยคลิกเมาสดานขวาที่ Desktop > New >Folder 
2. กําหนดชื่อตามที่ตองการ 
3. ดับเบิลคลิกเขาไปที่ โฟลเดอร  
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4. ใหทําการสรางโฟลเดอรสําหรับเก็บไฟลภาพ เพราะภาพทุกภาพที่ปรากฏบนเว็บ
จะตองนํามาเกบ็ไวที่นี้ รวมทัง้เมื่อนําไป Up load ไวบนเวบ็ ก็ตองนําโฟลเดอรนี้
ขึ้นไปดวยทุกครั้ง โดยคลิกเมาสขวาคลิกคําสั่ง New >Folder  

5. กําหนดชื่อโฟลเดอรวา Picture  
 
 
 
 
 
 
 

การสรางเว็บหนา Index  

การสราง เว็บหนาแรกตอง คํานึงการเปดหนาเว็บจริงถามีการเปดไดชา จะทําใหเกดิความ
เบื่อหนาย จนถึงขั้นไมเขาใชบริการ การสรางหนาแรกมีวิธีการกําหนดไดดังนี้ ในทีน่ี้ไดทําการเปด
โปรแกรม Dreamweaver ไวเพื่อสรางเว็บเพจ  

1. คลิกเมนู File > Save   
2. ที่ชอง Save in คลิกเลือกที่โฟลเดอรที่สรางจากขอที่ผานมา  
3. โดยตองกําหนดชื่อไฟลหนาแรกวา Index (ขอย้ําวา ไฟลของหนาที่ 1 ของเว็บ ตอง

กําหนดชื่อวา Index)  
4. คลิกปุม Save   

 
 
 
 
 
 



ตัวอยางโครงงาน   

 

โดยนายณัชพล  กาฬภักดี  ครู ชํานาญการ โรงเรียนบอกรุวิทยา สํานักงานเขตพื้นที่การศึกษาสุพรรณบุรี เขต 3 

11

การสรางขอความท่ี Title Bar  

 การสรางขอความที่ ซ่ึงสวนนี้จะเปนสวนที่ใชในการแสดงวา เว็บของเรามีคําจํากัดความวา
อยางไร  

1. กําหนดขอความที่ดานบนของ Title Bar โดยคลิกเมนู Modify > Page Properties  
2. พิมพขอความที่ชอง Title ตามที่ตองการ  
3. คลิกปุม Apply แลวคลิกปุม OK  

 
 
 
 
 
 
 
 
 

4. จากนั้นสรางขอความ 1 ขอความ  
5. ทดลองแสดงภาพตวัอยาง โดยคลิกปุม Preview > Preview in IExplore   

 
 
 
 
 
 
 
 
 
 

ขอความบน 
Title Bar 
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การกําหนด Style Sheets (CSS Style) 

ในการสรางขอความบางครั้งในกรณีที่ตองการจะกําหนดให ตวัอักษรมีขนาดเทากนัเมื่อ
นําไปเปดที่เครื่องก็ตาม เพราะโดยปกตินัน้เมื่อเราสรางเว็บดวยตวัอักษรแบบ หนึ่ง เมื่อนําไปไวบน 
อินเทอรเน็ต ปรากฏวา มีผูเขามาเยี่ยมชมเว็บ แลวกําหนดตัวอักษรที่โปรแกรมแสดงเว็บ เปนอกี
แบบซึ่งไมตรงกับตอนที่เราสราง ทําใหการแสดงภาพเวบ็ของเราจะเปลี่ยนไป ไมตรงกับความเปน
กับความตองการของผูสราง  

การกําหนด Style Sheets ใหกับตัวอักษร ในกรณีที่มีผูเขาชมเว็บ และไดกําหนดตวัอักษร
เปนรูปแบบอืน่ไมตรงตามทีเ่รากําหนดไวนั้น ตัวอักษรจะไมเปลี่ยนตาม โปรแกรม Browser ของ
เครื่องอื่น แตจะคงลักษณะเทาเดิม การกําหนด Style Sheets 

การสราง Style Sheets 

1.  คลิกเมนู Windows > CSS Styles  
2. คลิกปุม New CSS Styles  
 
 
 
 
 
 
3. กําหนดชื่อที่ชอง Name โดยตองกําหนดชือ่ใหมีจุดนําหนา ในที่นีจ้ะสรางไวเปน Style 

Sheets ของตัวอักษรที่เปนขอความหวัเร่ือง โดยกําหนดชื่อวา. HEAD  
4. คลิกปุม OK  
 
 
 
 
 

ปุม New CSS 
Styles 
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5. จากนั้นระบบจะกําหนดใหทําการบันทึก ใหบันทกึเก็บไวที่ โฟลเดอร Picture   
6. โดยกําหนดชือ่ตามที่ตองการ ในที่นี้จํากําหนดชื่อตามชือ่เว็บ  
7. คลิกปุม Save  
 
 
 
 
 
 
 

 
8. จากนั้นกําหนดรูปแบบตัวอักษร โดยในตอนแรกนีเ้ปนตัวอักษรของขอความหวัเร่ือง  

โดยกําหนดแบบ MS Sans Serif  
9. กําหนดขนาดที่ชอง Size โดยกําหนด ประมาณ 16 Pixel   และที่ชอง Weight กําหนด

แบบ Bold เพือ่ใหตัวอักษรมีความหนา  
10. ในที่นี้จะกําหนดสีใหกับตัวอักษร โดยกําหนดที่ชอง Color กําหนดสีแดง  
11. คลิกปุม Apply แลวคลิกปุม OK   
 
 
 
 
 
 
 
 
 
 

บันทึกที่โฟลเดอร 
Picture 

กําหนดชื่อ Style 
Sheets 
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12. จากนั้นทานทาํการสราง หลายๆ แบบ โดยใชกับตัวอักษรที่ตางกัน  
- ตัวอักษรที่เปนขอความปกติ (Body) 
- ขอความที่เปนจุดเชื่อมโยง (Link) 
- ขอความที่เปนหัวเร่ือง  (Head) 
 
 
 
 
 
 
 
 

การใชงาน Style Sheets 

หลังจากที่สราง Style Sheets มาแลว ตอนนี้ทดลองใชงาน Style Sheets กับตวัอักษร โดยมี
วิธีการกําหนดไดดังนี้  

1. ในที่นี้ทดลองสรางตัวอักษร ไวแลว หมายขอความ  
2. คลิกตัวอักษรที่เปนสวนของหัวเร่ือง  
3. คลิกที่ Styles Sheets แบบ Head จะเหน็วาตัวอักษรจะมีรูปแบบตาม Styles Sheets ที่

กําหนดไวตั้งแตแรก  
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4. คลิกที่ตัวอักษรที่จะกําหนดเปนจุดเชื่อมโยง  
5. คลิกที่ Styles Sheets แบบ Link จะเห็นวาตัวอักษรจะเปลี่ยนรูปแบบตาม Styles Sheets 

ที่กําหนด  
 
 

6. จากนั้นทานทาํการสราง หลายๆ แบบ โดยใชกับตัวอักษรที่ตางกัน  
 
 
 
 
 

การแกไข Style Sheets 

หลังจากที่สราง Style Sheets และทดลองใชงาน Style Sheets กับตวัอักษรไปแลว ในกรณี
ที่ทานตองการปรับแตงรูปแบบตัวอักษรของ Style Sheets ใหม  มีวิธีการกําหนดไดดงันี้  

1. ดับเบิลคลิกที่ Style Sheets ที่ตองการจะปรับแตง  
2. กําหนดขนาดตามตองการ  
3. คลิกปุม Apply แลวคลิกปุม OK ตอนนี้ตัวอักษรที่อยูบนเว็บทั้งหมดที่สรางมาจาก

ตัวอักษรแบบ Style Sheets จะเปลี่ยนแปลงรูปแบบตามที่เราปรับแตง  
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ขอตกลงเกี่ยวกับภาพ 

ในกรณีที่ทานสรางเว็บ แลวตองการจะนําภาพเขามาใชงานกับเว็บ โดยภาพที่จะนํามาใช
งานจะมีอยู 3 แบบ  

1. แบบ JPG จะเปนภาพที่มีขนาดเล็ก และใหสีที่สวยงาม นยิมนํามาทําเปนภาพประกอบ
ทั่วไป โดยไฟลงานแบบ นี้สีที่ไดจะมีถึง 16 ลานสี ซ่ึงเพียงพอกับความตองการ แต
ขอเสียคือ จะไมสามารถกําหนดความโปรงแสงใหกับภาพพื้นหลังได 

2. แบบ GIF ขอดีของไฟลชนดินี้คือสามารถนํามาสรางเปนภาพเคลื่อนไหวได โดยปกติ
นั้นถาเปนภาพนิ่งจะใชภาพแบบ JPG จะดกีวา (แตที่เห็นทั่วไปบางคนก็นิยมนําภาพ
แบบ GIF มาสรางเปนภาพนิง่ก็ไมผิดกตกิา ) และขอดีอีกอยางของไฟลงานแบบ GIF 
คือจะสามารถสรางไฟลงานแบบพื้นหลัง Transparence (พื้นหลังโปรงแสง) ขอเสีย
ของภาพแบบนี้จะมีสีเพยีง 256 สีเทานั้นจะเห็นวาสีของภาพถาเปนสีที่มีความละเอียด
สูงจะเปนสีที่ดานๆ ไมสวยเทากบั JPG  

3. แบบ PNG แบบนี้ จะเปนไฟลที่รวมนําเอาคุณสมบัติเดนของไฟลงานแบบ JPG และ 
แบบ GIF มารวมกัน กลาวคอื สามารถกําหนดใหภาพมคีวามละเอียดสีไดสูงถึง 16 
ลานสี และสามารถกําหนดความโปรงแสงของภาพพื้นหลังได แตขอเสียคือจะมีขนาด
ของไฟลภาพใหญกวาภาพแบบ อ่ืนเมื่อเปรียบเทียบที่มีขนาดเทากนั  
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ขนาดของภาพที่จะนํามาใชงานในเว็บ  

ในกรณีที่จะนาํภาพเขามาใชงานกับเว็บ ในกรณีที่จะนําภาพเขามาใชงานที่ขนาด 7 X 5 
เซนติเมตร ภาพที่จะนาํมาใชงานควรไปกําหนดขนาดที่โปรแกรม PhotoShop กอนทีจ่ะนํามาใชงาน 
และที่คาความละเอียด หรือคา Resolution ก็ใหกําหนดทีข่นาด 72 Pixel/Inch เทานั้น เพราะไมวาจะ
กําหนดความละเอียดเทาไร คาของหนาจอที่สามารถแสดงผลได จะมีคาที่ 72 Pixel/Inch เทานั้น อีก
ทั้งยังสามารถที่จะลดน้ําหนกัของภาพลงไดอีกหลายเปอรเซน็ต  

การกําหนดขนาดที่โปรแกรม PhotoShop ใหกําหนดที่คาํสั่ง เมนู Image > Image Size  
 
 
 
 
 
 
 
 
 
 

การยายภาพเขามาเก็บไวท่ีโฟลเดอร Picture   
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การนําภาพเขามาใชในเว็บ  

การนําภาพเขามาใชงานกับเว็บ มีวิธีการกําหนดไดดังนี้  
1. คลิกเมนู Insert > Image  
 
 
 
 
 
 
 
2. ที่ชอง Look In เปดที่ โฟลเดอร Picture  
3. คลิกเลือกภาพเขามาใชงาน  
4. คลิกปุม OK   
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การสรางตาราง  

ในตอนนีเ้ราจะเรียนรูการทํางานเกีย่วกับตาราง ซ่ึงตารางจะใชในการจดัเรียงขอมูลที่เปน
ตัวเลขจํานวนมากๆ หรือที่เรียกวา ฐานขอมูล  

1. ขั้นแรกคลิกแทบ Common  
2. คลิกปุม Insert Table  

 
 
 
 
 

3. กําหนดขนาดตารางที่ชอง Width เปน 400 Pixel  
4. จํานวนตารางแนวนอนที่ชอง Rows เปน 3  และที่ชอง Columns เปน 1  
5. กําหนดความกวางของของตารางที่ชอง Cell Padding และ Cell Spacing เปน 2  
6. คลิกปุม OK  

 
 
 
 
 
 

7. หลังจากที่สรางตารางมาในกรณีที่จะปรับแตง ใหแดรกเมาสที่เสนของกําหนดขนาด
ตามตองการ  
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8. ใหทําการกรอกขอมูลตามที่ตองการ  
 
 
 
 
 

การสรางหนาเว็บท่ีสอง   

การสรางหนาเว็บที่สอง มีวิธีการกําหนดไดดังนี้  
1. คลิกเมนู File > New  
2. คลิกปุม Create  
3. กอนอื่นใหทําการบันทึก โดยคลิกเมนู File > Save โดยกาํหนดชื่อใหส่ือถึงหนาที่สอง    
4. จากนั้นใหสรางหนาเว็บใหมตามที่ตองการ  
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การเชื่อมโยง (Link) 

ในการสรางเวบ็สิ่งที่สําคัญไดแกการเชื่อมโยง โดยหลักในการเชื่อมโยงของเว็บจะมหีลาย
อยาง ไดแก  

1. การเชื่อมโยงดวยตวัอักษร 
2. การเชื่อมโยงดวยภาพ  
3. การเชื่อมโยงดวยปุม  
4. การเชื่อมโยงกบั e-mail  

การเชื่อมโยงดวยตัวอักษร  

ในการเชื่อมโยงดวยตวัอักษร โดยสังเกตวาตัวอักษรตวัใดที่สามารถเชื่อมโยงได เมื่อนํา
เมาสมาวางที่ตวัอักษร เมาสจะเปลี่ยนเปนรูปมือ การกําหนดใหตัวอักษรเชื่อมโยง มีวธีิการดังนี้  

1. สรางขอความที่จะกําหนดใหเปนจดุเชื่อมโยง แดรกเมาสที่ขอความ  
2. ที่ชอง Link โดยกําหนดตําแหนงที่ตองการจะใหเชื่อมโยง  
- กรณีจะเชื่อมโยงภายในเว็บ เชน search.htm (โดยคําวา search หมายถึงชื่อเว็บที่สอง 

สวน.html เปนไฟลนามสกลุ) 
- กรณีที่จะเชื่อมโยงไปยังเว็บอืน่ ใหกําหนดวา http://www.siam.com   
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การเชื่อมโยงดวยภาพ  

ในการเชื่อมโยงดวยภาพ โดยมากจะเปนการเชื่อมโยงไปยังเว็บเพื่อขยายขอความ  
1. นําภาพเขามาใชงาน 1 ภาพ  
2. กําหนดการเชือ่มโยง โดยคลิกที่ภาพ  
3. กําหนดที่ชอง Link โดยกําหนดตําแหนงทีต่องการจะใหเชื่อมโยง  
- กรณีจะเชื่อมโยงภายในเว็บ เชน search.htm (โดยคําวา search หมายถึงชื่อเว็บที่สอง 

สวน.html เปนไฟลนามสกลุ) 
- กรณีที่จะเชื่อมโยงไปยังเว็บอืน่ ใหกําหนดวา http://www.siam.com   

 
 
 
 
 
 
 
 
 
 
 
 
 
4. จากนั้นทดลองแสดงภาพ โดยคลิกปุม Preview  
5. ในกรณีที่จะเชือ่มโยงใหคลิกที่ภาพ จะเชื่อมโยงไปยังเวบ็ที่ตองการ   
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การเชื่อมโยงดวยปุม  

 ในกรณีที่จะเชือ่มโยงดวยปุม แบบนี้จะเปนการเพิ่มเทคนคิในการเพิ่มความนาสนใจ ใหกับ
เว็บเพจ็ โดยขัน้ตอนดังตอไปนี้  

กอนอื่น ใหทําการสรางที่จะนํามาสรางปุมไวทั้งหมด 2 ภาพ โดยสรางปุมที่มีขนาด 200 
คูณ 30 Pixel โดยใชภาพแบบเดียวกัน แตตางกันที่สีของปุม  
 

 
1. คลิกแทบ Common คลิกปุม Rollover Image  

 
 
 
 
 

2. ชอง Original Image ใชกําหนดภาพที่ 1 โดยคลิกปุม Browse คลิกเลือกภาพทีจ่ะใชงาน  
3. ชอง Rollover Image ใชกําหนดภาพที่ 2 นั้นก็คือในขณะคลิกเมาส โดยคลิกปุม 

Browse แลวคลิกเลือกภาพที ่2  
4. ชอง Alternate Text พิมพขอความที่ตองการใหปรากฏขึ้น เมื่อนําเมาสมาวางที่ปุม  
5. ที่ชอง When Clicked, Go to URL ใชกําหนดตําแหนงที่จะเชื่อมโยง โดยพิมพช่ือเวบ็ที่

ตองการจะเชื่อมโยง  
6. คลิกปุม OK  
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7. ทดลองแสดงภาพ โดยคลิกปุม Preview in Browser นํามามาวางที่ปุม ตอนนี้ทาน
สามารถสรางปุม แบบ Rollover ไดแลวครับ  
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บทที่ 3 
วิธีการดําเนนิการ และอุปกรณ 

วิธีดําเนินการ  
1. แบงกลุมการจดัทําออกเปน 4 กลุม  

กลุมที่ 1 รับผิดชอบเกี่ยวกับการสรางเว็บ และโปรแกรมในการสรางเวบ็  
กลุมที่ 2 รับผิดชอบเกี่ยวกับการออกแบบโครงสรางหนาเว็บใหสวยงาม  
กลุมที่ 3 รับผิดชอบเกี่ยวกับการหาขอมูล  
กลุมที่ 4 รับผิดชอบเกี่ยวกับการจัดหาเนื้อที่ในการสรางเว็บเพจของหอง  

โปรแกรมในการสรางเว็บ 
ศึกษาโปรแกรมสําเร็จรูปที่ใชในการสรางเว็บเพจ ไดแก Macromedia Dreamweaver, 

Microsoft FrontPage ศึกษาจากการอานหนงัสือ และผูเชี่ยวชาญในการสรางเว็บเพจ  

ออกแบบโครงสรางหนาเว็บใหสวยงาม 
ในสวนนี้จะทาํงานควบคูกับการใชงานโปรแกรมในการสรางเว็บเพจ โดยจะรับผิดชอบกับ

การออกแบบโครงสรางเว็บใหสวยงาม  
ออกแบบการเชื่อมโยงเว็บ ภายในเว็บ ออกแบบการเชื่อมโยงกับแหลงขอมูลอ่ืนๆ  

การหาขอมูล 
การรวบรวมขอมูล แบงออกเปน 2 แบบ  
1. รวบรวมขอมลูเกี่ยวกับประวิสวนตวั และประวัติของโรงเรียน  
2. รวบรวมขอมลูเกี่ยวกับเนื้อหาความรู  

การขอเนื้อท่ีในการสรางเว็บเพจ  
ดําเนินการขอเนื้อที่ ของเว็บ www.geocities.com โดยทําตามขั้นตอนการลงทะเบียนของ

เว็บ ไดทนัที่  
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บทที่ 4 
ผลการศึกษา                   

 
การสรางเว็บเพจ เกีย่วกับการนําเสนอขอมูล จะประกอบดวย 4 ขั้นตอน  

 
กลุมที่ 1 รับผิดชอบเกี่ยวกับการสรางเว็บ และโปรแกรมในการสรางเวบ็  
จากการศึกษากระบวกการสรางเว็บเพจ การสรางเว็บควรใชโปรแกรม Dreamweaver ใน

การสราง เพราะความสามารถจะครอบคลุมการใชงาน ทัง้หมด  
 
 
 
 
 

 
 

กลุมที่ 2 รับผิดชอบเกี่ยวกับการออกแบบโครงสรางหนาเว็บใหสวยงาม  
จากการศึกษา พบวามีขั้นตอนของการเชื่อมโยง ดังภาพ  

 
 
 
 
 
 
 
 
 

หนาแรก 

ประวัติโรงเรียน 

สถานที่ต้ัง ประวัติ
โรงเรียน 

ทําเนียบ
ผูบริหาร 

อาจารย/บุคลากร 

ประวัติ
สวนตัว 

วิชาที่
สอน 

บุคคลที่สรางชื่อเสียง
และผลงานตางๆ 

ดาน
ความรู 

ดาน
กีฬา 

ดาน
สังคม 
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กลุมที่ 3 รับผิดชอบเกี่ยวกับการหาขอมูล  
จากการศึกษา วิธีการหาขอมลูของบุคคลตาง จะใชวิธีการสงแบบสํารวจแลวใหผูนั้นทาํการ

กรอกขอมูล  
การรวบรวมขอมูล แบงออกเปน 2 แบบ  
1. รวบรวมขอมลูเกี่ยวกับประวิสวนตวั และประวัติของโรงเรียน  
2. รวบรวมขอมลูเกี่ยวกับเนื้อหาความรู  
 

ตัวอยางแบบฟอรมท่ีใชในการบันทึกของหองเรียน 
ชั้น ......... 

ช่ือ............................................... นามสกุล.....................................เลขที่................ 
อายุ...................เพศ....................สวนสูง............................น้ําหนกั...................... 
ที่อยู....................................................................................................................... 
.............................................................................................................................. 
.............................................................................................................................. 
โทรศัพท.................................. 
บิดาชื่อ..........................................................................อาชีพ............................... 
มารดาชื่อ.......................................................................อาชีพ................................ 
มีพี่นอง........................คน เปนคนที.่......................................................... 
 
 
กลุมที่ 4 รับผิดชอบเกี่ยวกับการจัดหาเนื้อที่ในการสรางเว็บเพจของหอง  

 จากผลการศึกษาพบวา การดําเนินขอเนื้อที่ไดจากเว็บ www.geocities.com โดยทําตาม
ขั้นตอนของการลงทะเบียนของเว็บ ไดทนัที่  
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บทที่ 5 
สรุปผลการศึกษา 

การขอเนื้อที่สําหรับเว็บที่เปดใหใชบริการฟรี จะมีขอจํากับหลายอยาง เชน เนื้อที่นอย มี
การโฆษณาจํานวนมาก การเขาถึงขอมูลไดยาก เพราะตองผานขั้นตอนการดําเนินการหลายขั้นตอน  

ควรจะทําแบบที่จดชื่อเอง โดยเสียงคาจองชือ่คร้ังแรก 450 บาทตอช่ือ  
สวนคาเชาเนื้อที่ 100 mb จะเสียคาบริการ 1200 บาท ตอป ซ่ึงเนื้อที่นี้จะเพียงพอตอการ

ใหบริการ  
รวมแลวจะเสยีเงนิปแรก จํานวนเงนิ 1600 บาท  
โดยเว็บที่เปดใหบริการไดแก www.ohohost.com  
ในกรณีที่ไมมงีบประมาณในการจัดเก็บ ควรใชการเก็บเงินทั้งโรงเรียน ในกรณีที่มนีักเรียน 

1000 คน จะจดัเก็บเพยีงคนละ 2 บาท ซ่ึงถือวานอยมากในการจดัเก็บ  
 

ประโยชนท่ีไดรับ  

1. เพื่อจัดทําเว็บเพจ เพื่อนําเสนอขอมูล เกี่ยวกบัโรงเรียน  
2. เพื่อเปนแหลงเรียนรูของนักเรียนบุคคลทั่วๆ ไป  
3. เพื่อใหนักเรยีนมีสวนรวมในการจัดทําเวบ็เพจ  
4. เพื่อใหนักเรยีนมีจิตสํานึกในการใชเทคโนโลยีสาระสนเทศ  
 

ขอเสนอแนะ  

1. การจัดทําควรมีการฝกอบรมขั้นตอนการทาํควรคูไปดวย   
2. ควรมีคูมือในการใชงานโปรแกรมมากกวานี้  
3. ควรมีการจัดเก็บเงินกองกลางเพื่อใชในขั้นตอนของการทํางาน 
 
 
 



ตัวอยางโครงงาน   
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